composer.json 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. {
  2. "name": "yiisoft/yii2-app-advanced",
  3. "description": "Yii 2 Advanced Project Template",
  4. "keywords": ["yii2", "framework", "advanced", "project template"],
  5. "homepage": "http://www.yiiframework.com/",
  6. "type": "project",
  7. "license": "BSD-3-Clause",
  8. "support": {
  9. "issues": "https://github.com/yiisoft/yii2/issues?state=open",
  10. "forum": "http://www.yiiframework.com/forum/",
  11. "wiki": "http://www.yiiframework.com/wiki/",
  12. "irc": "irc://irc.freenode.net/yii",
  13. "source": "https://github.com/yiisoft/yii2"
  14. },
  15. "minimum-stability": "stable",
  16. "require": {
  17. "php": ">=5.4.0",
  18. "yiisoft/yii2": "~2.0.14",
  19. "yiisoft/yii2-bootstrap": "~2.0.0",
  20. "yiisoft/yii2-swiftmailer": "~2.0.0 || ~2.1.0",
  21. "workerman/gateway-worker": "^3.0",
  22. "qiniu/php-sdk": "^7.2",
  23. "apanly/browser-detector": "dev-master"
  24. },
  25. "require-dev": {
  26. "yiisoft/yii2-debug": "~2.0.0",
  27. "yiisoft/yii2-gii": "~2.0.0",
  28. "yiisoft/yii2-faker": "~2.0.0",
  29. "codeception/base": "^2.4.0",
  30. "phpunit/phpunit": "~6.5.5",
  31. "codeception/verify": "~1.0.0"
  32. },
  33. "config": {
  34. "process-timeout": 1800,
  35. "secure-http": false,
  36. "fxp-asset": {
  37. "enabled": false
  38. }
  39. },
  40. "repositories": {
  41. "packagist": {
  42. "type": "composer",
  43. "url": "http://packagist.phpcomposer.com"
  44. }
  45. }
  46. }